CAN-BUS e Garmin: il connubio potrebbe non essere troppo felice

Attenzione possessori di una moto con CAN-BUS, questo articolo è pensato prevalentemente per voi e per chi, ovviamente, ha installato un navigatore Garmin della serie ZUMO.

Da qualche tempo la mia moto (BMW F800 GS del 2009) sta avendo problemi di alimentazione. Una volta è la batteria. Una volta il regolatore di tensione ma ieri sera, quando la moto mi ha lasciato ad un benzinaio, da solo, con 6 gradi centigradi, ho deciso che forse era il caso di cominciare a porsi qualche domanda differente. Mentre la mia ragazza mi portava (santa donna) la batteria di ricambio (che ormai tengo sempre in casa). Mi sono deciso a contattare una persona che per la prima volta mi ha sottoposto un problema.

Il CAN-BUS non è infallibile. È possibile che il suo funzionamento venga compromesso (temporaneamente) da accessori come il Garmin. Generalmente questo si verifica dando delle avvisaglie. Ad esempio il GARMIN non si spegne quando si gira la chiave.

Ho cominciato ad indagare poichè il mio Garmin ZUMO 590LM è attaccato alla porta di servizio del CAN-BUS. Pensavo, avendo avuto anche un TomTom che il problema non ci sarebbe stato e invece… così mi sono messo a cercare su Internet e ho trovato un messaggio di Quellidellelica.

Dal 2010 in poi il can-bus della moto lavora in modo diverso e toglie sempre corrente all’impianto moto dopo i 60 secondi. Nelle versioni precedenti, se c’era un assorbimento sotto una certa soglia veniva scambiato per la tensione del caricabatterie e le porte rimanevano aperte.

Molto spesso il problema quindi nasce dall’accoppiata CAN-BUS PRESA DI SERVIZIO + CAVO ACCENDISIGARI.

il problema deriva dall’assorbimento del cavo accendisigari che è minore di quello del navi ma non è nullo ed l can-bus rimane “attivo”.

 Al momento ho staccato il Garmin dalla presa di servizio e con la batteria installata, sto effettuando delle prove per capire se la causa possa esser quella. Ovviamente mi servirà del tempo per capirlo ma vi terrò informati, nel frattempo mi sto massaggiando con un utente del sito Quellidellelica chiamato Taz (www.tazmoto.it). Questa persona, molto cortese, mi ha informato di un modo per parallelizzare il circuito partendo dal connettore diagnostico del GS di cui vi riporto un paio di foto.

Come potete vedere il contatto contrassegnato con il numero 6 sul connettore di diagnostica, corrisponde al 16 sul connettore OBD-II e trasporta i 12+V della batteria. Nell’ultima foto, quella con il plug cilindrico, potete notare la soluzione di TAZ.

Il filo rosso che entra, è direttamente connesso con il pin numero 6, ossia con i +12 volt. Il cavo rosso è il positivo del navigatore. Il cavo negativo è, invece, direttamente connesso alla batteria della moto. Taz, per infilare il cavo, ha praticato un piccolo foro sul coperchio e poi usando un connettore tondo, ha praticato il collegamento. Parliamo di un connettore MC4 che, essendo di forma cilindrica, si inserisce nel maschio di cui vedete la foto.

coppia-di-connettori-mc4-179

Questo è un classico esempio. Il primo è il maschio (che non ci serve), il secondo è la femmina che, dal lato sinistro accoglie il cavo, dal lato destro deve essere infilato nel connettore CAN-BUS.

In questo modo il circuito sarà comunque sotto-chiave, e questo significa che non consumerà tutta la corrente della moto. Tal ha attaccato al filo rosso un relè, che gli consente di avere più dispositivi connessi. Quello vedetelo voi, io vi riporto uno schema di connessione proveniente dal sito GSRIDER a cura dell’utente Mambo e pensato per un Gs 1200.

ImpiangoParalleloMamboGs1200

Per completezza trovate qui il file in PDF originale.

Impianto Parallelo GS1200 by Mambo

In conclusione, non so cosa ha la mia moto ma questa esperienza ha aperto un’interessante mondo sull’elettronica del GS, mostrando caratteristiche che, secondo me, è sempre bene conoscere.

Quello che posso dirvi riguardante la mia moto, è che il problema non è stato causato dal navigatore (bastava staccare la presa di servizio e valutare gli impatti energetici). Grazie a Santi Moto sono stati effettuati alcuni test per valutare dispersioni, possibili problemi nell’erogazione dell’energia che, però, non sono stati riscontrati. Il problema, di conseguenza, è sembrato esser solo la batteria “fiacca” nell’accensione. Sostituendola con una originale BMW faremo la prova per capire se i difetti di alimentazione rimarranno oppure no.

Vi aspetto al prossimo articolo.

Condividilo su:

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *